cheep-crator-2/Cargo.toml

2677 lines
57 KiB
TOML
Raw Permalink Normal View History

2022-07-19 10:54:41 +00:00
[package]
name = "cheep-crator-2"
version = "0.1.0"
edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
2022-07-19 11:04:30 +00:00
# https://github.com/integer32llc/rust-playground/blob/100bc9f98ef12b77c573235ba3fcc5f7ef336fb2/compiler/base/Cargo.toml#L19
[dependencies.addr2line]
package = "addr2line"
version = "=0.17.0"
default-features = false
[dependencies.adler]
package = "adler"
version = "=1.0.2"
default-features = false
[dependencies.adler32]
package = "adler32"
version = "=1.2.0"
features = ["std"]
[dependencies.ahash]
package = "ahash"
version = "=0.7.6"
default-features = false
[dependencies.aho_corasick]
package = "aho-corasick"
version = "=0.7.18"
features = ["std"]
[dependencies.ansi_term]
package = "ansi_term"
version = "=0.12.1"
[dependencies.anyhow]
package = "anyhow"
version = "=1.0.58"
features = ["std"]
[dependencies.approx]
package = "approx"
version = "=0.5.1"
features = ["std"]
[dependencies.arc_swap]
package = "arc-swap"
version = "=1.5.0"
[dependencies.arrayvec]
package = "arrayvec"
version = "=0.7.2"
features = ["std"]
[dependencies.async_recursion]
package = "async-recursion"
version = "=1.0.0"
[dependencies.async_trait]
package = "async-trait"
version = "=0.1.56"
[dependencies.atty]
package = "atty"
version = "=0.2.14"
[dependencies.autocfg]
package = "autocfg"
version = "=1.1.0"
[dependencies.backtrace]
package = "backtrace"
version = "=0.3.65"
features = ["std"]
[dependencies.base64]
package = "base64"
version = "=0.13.0"
features = ["std"]
[dependencies.bit_field]
package = "bit_field"
version = "=0.10.1"
[dependencies.bit_set]
package = "bit-set"
version = "=0.5.2"
features = ["std"]
[dependencies.bit_vec]
package = "bit-vec"
version = "=0.6.3"
features = ["std"]
default-features = false
[dependencies.bitflags]
package = "bitflags"
version = "=1.3.2"
[dependencies.block_buffer]
package = "block-buffer"
version = "=0.10.2"
[dependencies.bstr]
package = "bstr"
version = "=0.2.17"
features = ["lazy_static", "regex-automata", "serde", "serde1", "serde1-nostd", "std", "unicode"]
[dependencies.bytemuck]
package = "bytemuck"
version = "=1.10.0"
features = ["bytemuck_derive", "derive", "extern_crate_alloc", "extern_crate_std", "min_const_generics", "wasm_simd", "zeroable_maybe_uninit"]
[dependencies.bytemuck_derive]
package = "bytemuck_derive"
version = "=1.1.0"
[dependencies.byteorder]
package = "byteorder"
version = "=1.4.3"
features = ["std"]
[dependencies.bytes]
package = "bytes"
version = "=1.1.0"
features = ["std"]
[dependencies.bytes_0_4_12]
package = "bytes"
version = "=0.4.12"
[dependencies.cc]
package = "cc"
version = "=1.0.73"
[dependencies.cfg_if]
package = "cfg-if"
version = "=1.0.0"
[dependencies.chrono]
package = "chrono"
version = "=0.4.19"
features = ["clock", "libc", "oldtime", "serde", "std", "time", "winapi"]
[dependencies.clap]
package = "clap"
version = "=3.2.8"
features = ["atty", "cargo", "clap_derive", "color", "derive", "env", "once_cell", "regex", "std", "strsim", "suggestions", "termcolor", "terminal_size", "unicase", "unicode", "unstable-doc", "unstable-grouped", "unstable-replace", "wrap_help", "yaml", "yaml-rust"]
[dependencies.clap_derive]
package = "clap_derive"
version = "=3.2.7"
[dependencies.clap_lex]
package = "clap_lex"
version = "=0.2.4"
[dependencies.color_quant]
package = "color_quant"
version = "=1.1.0"
[dependencies.cookie]
package = "cookie"
version = "=0.16.0"
features = ["percent-encode", "percent-encoding"]
[dependencies.cookie_store]
package = "cookie_store"
version = "=0.16.1"
[dependencies.cpufeatures]
package = "cpufeatures"
version = "=0.2.2"
[dependencies.crc32fast]
package = "crc32fast"
version = "=1.3.2"
features = ["std"]
[dependencies.crossbeam]
package = "crossbeam"
version = "=0.8.1"
features = ["alloc", "crossbeam-channel", "crossbeam-deque", "crossbeam-epoch", "crossbeam-queue", "std"]
[dependencies.crossbeam_channel]
package = "crossbeam-channel"
version = "=0.5.5"
features = ["crossbeam-utils", "std"]
[dependencies.crossbeam_deque]
package = "crossbeam-deque"
version = "=0.8.1"
features = ["crossbeam-epoch", "crossbeam-utils", "std"]
[dependencies.crossbeam_epoch]
package = "crossbeam-epoch"
version = "=0.9.9"
features = ["alloc", "once_cell", "std"]
[dependencies.crossbeam_queue]
package = "crossbeam-queue"
version = "=0.3.5"
features = ["alloc", "std"]
default-features = false
[dependencies.crossbeam_utils]
package = "crossbeam-utils"
version = "=0.8.10"
features = ["once_cell", "std"]
[dependencies.crypto_common]
package = "crypto-common"
version = "=0.1.4"
features = ["std"]
[dependencies.csv]
package = "csv"
version = "=1.1.6"
[dependencies.csv_core]
package = "csv-core"
version = "=0.1.10"
[dependencies.data_encoding]
package = "data-encoding"
version = "=2.3.2"
features = ["alloc", "std"]
[dependencies.debug_unreachable]
package = "new_debug_unreachable"
version = "=1.0.4"
[dependencies.deflate]
package = "deflate"
version = "=1.0.0"
[dependencies.derivative]
package = "derivative"
version = "=2.2.0"
[dependencies.digest]
package = "digest"
version = "=0.10.3"
features = ["alloc", "block-buffer", "core-api", "mac", "std", "subtle"]
[dependencies.either]
package = "either"
version = "=1.7.0"
features = ["use_std"]
[dependencies.encoding_rs]
package = "encoding_rs"
version = "=0.8.31"
features = ["alloc"]
[dependencies.env_logger]
package = "env_logger"
version = "=0.9.0"
features = ["atty", "humantime", "regex", "termcolor"]
[dependencies.error_chain]
package = "error-chain"
version = "=0.12.4"
features = ["backtrace", "example_generated"]
[dependencies.exr]
package = "exr"
version = "=1.4.2"
[dependencies.fallible_iterator]
package = "fallible-iterator"
version = "=0.2.0"
features = ["std"]
[dependencies.fallible_streaming_iterator]
package = "fallible-streaming-iterator"
version = "=0.1.9"
[dependencies.fastrand]
package = "fastrand"
version = "=1.7.0"
[dependencies.filetime]
package = "filetime"
version = "=0.2.17"
[dependencies.fixedbitset]
package = "fixedbitset"
version = "=0.4.2"
default-features = false
[dependencies.flate2]
package = "flate2"
version = "=1.0.24"
features = ["miniz_oxide", "rust_backend"]
[dependencies.flume]
package = "flume"
version = "=0.10.13"
features = ["async", "eventual-fairness", "futures-core", "futures-sink", "nanorand", "pin-project", "select"]
[dependencies.fnv]
package = "fnv"
version = "=1.0.7"
features = ["std"]
[dependencies.foreign_types]
package = "foreign-types"
version = "=0.3.2"
[dependencies.foreign_types_shared]
package = "foreign-types-shared"
version = "=0.1.1"
[dependencies.form_urlencoded]
package = "form_urlencoded"
version = "=1.0.1"
[dependencies.futf]
package = "futf"
version = "=0.1.5"
[dependencies.futures]
package = "futures"
version = "=0.3.21"
features = ["alloc", "async-await", "compat", "executor", "futures-executor", "io-compat", "std", "thread-pool"]
[dependencies.futures_0_1_31]
package = "futures"
version = "=0.1.31"
features = ["use_std", "with-deprecated"]
[dependencies.futures_channel]
package = "futures-channel"
version = "=0.3.21"
features = ["alloc", "futures-sink", "sink", "std"]
[dependencies.futures_core]
package = "futures-core"
version = "=0.3.21"
features = ["alloc", "std"]
[dependencies.futures_executor]
package = "futures-executor"
version = "=0.3.21"
features = ["num_cpus", "std", "thread-pool"]
default-features = false
[dependencies.futures_io]
package = "futures-io"
version = "=0.3.21"
features = ["std"]
default-features = false
[dependencies.futures_macro]
package = "futures-macro"
version = "=0.3.21"
[dependencies.futures_sink]
package = "futures-sink"
version = "=0.3.21"
features = ["alloc", "std"]
[dependencies.futures_task]
package = "futures-task"
version = "=0.3.21"
features = ["alloc", "std"]
[dependencies.futures_util]
package = "futures-util"
version = "=0.3.21"
features = ["alloc", "async-await", "async-await-macro", "channel", "compat", "futures-channel", "futures-io", "futures-macro", "futures-sink", "futures_01", "io", "io-compat", "memchr", "sink", "slab", "std", "tokio-io"]
[dependencies.generic_array]
package = "generic-array"
version = "=0.14.5"
features = ["more_lengths"]
[dependencies.getrandom]
package = "getrandom"
version = "=0.2.7"
features = ["js", "js-sys", "rdrand", "std", "wasm-bindgen"]
[dependencies.getrandom_0_1_16]
package = "getrandom"
version = "=0.1.16"
features = ["std"]
[dependencies.gif]
package = "gif"
version = "=0.11.4"
features = ["raii_no_panic", "std"]
[dependencies.gimli]
package = "gimli"
version = "=0.26.1"
features = ["read", "read-core"]
default-features = false
[dependencies.glob]
package = "glob"
version = "=0.3.0"
[dependencies.h2]
package = "h2"
version = "=0.3.13"
[dependencies.half]
package = "half"
version = "=1.8.2"
[dependencies.hashbrown]
package = "hashbrown"
version = "=0.12.1"
features = ["ahash", "inline-more", "raw"]
[dependencies.hashbrown_0_11_2]
package = "hashbrown"
version = "=0.11.2"
features = ["ahash", "inline-more"]
[dependencies.hashlink]
package = "hashlink"
version = "=0.7.0"
[dependencies.heck]
package = "heck"
version = "=0.4.0"
[dependencies.hmac]
package = "hmac"
version = "=0.12.1"
[dependencies.html5ever]
package = "html5ever"
version = "=0.25.2"
[dependencies.http]
package = "http"
version = "=0.2.8"
[dependencies.http_body]
package = "http-body"
version = "=0.4.5"
[dependencies.httparse]
package = "httparse"
version = "=1.7.1"
features = ["std"]
[dependencies.httpdate]
package = "httpdate"
version = "=1.0.2"
[dependencies.humantime]
package = "humantime"
version = "=2.1.0"
[dependencies.hyper]
package = "hyper"
version = "=0.14.19"
features = ["client", "full", "h2", "http1", "http2", "runtime", "server", "socket2", "stream", "tcp"]
[dependencies.hyper_tls]
package = "hyper-tls"
version = "=0.5.0"
[dependencies.idna]
package = "idna"
version = "=0.2.3"
[dependencies.image]
package = "image"
version = "=0.24.2"
features = ["bmp", "dds", "dxt", "exr", "farbfeld", "gif", "hdr", "ico", "jpeg", "jpeg_rayon", "openexr", "png", "pnm", "scoped_threadpool", "tga", "tiff", "webp"]
[dependencies.indexmap]
package = "indexmap"
version = "=1.9.1"
features = ["std"]
[dependencies.inflate]
package = "inflate"
version = "=0.4.5"
[dependencies.iovec]
package = "iovec"
version = "=0.1.4"
[dependencies.ipnet]
package = "ipnet"
version = "=2.5.0"
[dependencies.itertools]
package = "itertools"
version = "=0.10.3"
features = ["use_alloc", "use_std"]
[dependencies.itoa]
package = "itoa"
version = "=1.0.2"
[dependencies.itoa_0_4_8]
package = "itoa"
version = "=0.4.8"
features = ["std"]
[dependencies.jpeg_decoder]
package = "jpeg-decoder"
version = "=0.2.6"
features = ["rayon"]
default-features = false
[dependencies.lazy_static]
package = "lazy_static"
version = "=1.4.0"
[dependencies.lebe]
package = "lebe"
version = "=0.5.1"
[dependencies.libc]
package = "libc"
version = "=0.2.126"
features = ["std"]
[dependencies.libm]
package = "libm"
version = "=0.2.2"
[dependencies.libsqlite3_sys]
package = "libsqlite3-sys"
version = "=0.24.2"
features = ["bundled", "bundled_bindings", "cc", "min_sqlite_version_3_6_23", "min_sqlite_version_3_6_8", "min_sqlite_version_3_7_7", "pkg-config", "unlock_notify", "vcpkg"]
[dependencies.linked_hash_map]
package = "linked-hash-map"
version = "=0.5.6"
[dependencies.lock_api]
package = "lock_api"
version = "=0.4.7"
[dependencies.log]
package = "log"
version = "=0.4.17"
features = ["serde", "std"]
[dependencies.log4rs]
package = "log4rs"
version = "=1.1.1"
features = ["all_components", "ansi_writer", "chrono", "compound_policy", "config_parsing", "console_appender", "console_writer", "delete_roller", "file_appender", "fixed_window_roller", "humantime", "json_encoder", "libc", "log-mdc", "parking_lot", "pattern_encoder", "rolling_file_appender", "serde", "serde-value", "serde_json", "serde_yaml", "simple_writer", "size_trigger", "thread-id", "threshold_filter", "typemap", "winapi", "yaml_format"]
[dependencies.log_mdc]
package = "log-mdc"
version = "=0.1.0"
[dependencies.mac]
package = "mac"
version = "=0.1.1"
[dependencies.markup5ever]
package = "markup5ever"
version = "=0.10.1"
[dependencies.markup5ever_rcdom]
package = "markup5ever_rcdom"
version = "=0.1.0"
[dependencies.matches]
package = "matches"
version = "=0.1.9"
[dependencies.matrixmultiply]
package = "matrixmultiply"
version = "=0.3.2"
features = ["cgemm", "std"]
[dependencies.md5]
package = "md5"
version = "=0.7.0"
features = ["std"]
[dependencies.memchr]
package = "memchr"
version = "=2.5.0"
features = ["std"]
[dependencies.memmap]
package = "memmap"
version = "=0.7.0"
[dependencies.memoffset]
package = "memoffset"
version = "=0.6.5"
[dependencies.mime]
package = "mime"
version = "=0.3.16"
[dependencies.mime_guess]
package = "mime_guess"
version = "=2.0.4"
default-features = false
[dependencies.miniz_oxide]
package = "miniz_oxide"
version = "=0.5.3"
[dependencies.mio]
package = "mio"
version = "=0.8.4"
features = ["net", "os-ext", "os-poll"]
[dependencies.nalgebra]
package = "nalgebra"
version = "=0.31.0"
features = ["macros", "matrixmultiply", "nalgebra-macros", "std"]
[dependencies.nalgebra_macros]
package = "nalgebra-macros"
version = "=0.1.0"
[dependencies.nanorand]
package = "nanorand"
version = "=0.7.0"
features = ["alloc", "chacha", "getrandom", "pcg64", "std", "tls", "wyrand"]
[dependencies.native_tls]
package = "native-tls"
version = "=0.2.10"
[dependencies.ndarray]
package = "ndarray"
version = "=0.15.4"
features = ["std"]
[dependencies.num]
package = "num"
version = "=0.4.0"
features = ["num-bigint", "std"]
[dependencies.num_bigint]
package = "num-bigint"
version = "=0.4.3"
features = ["std"]
default-features = false
[dependencies.num_complex]
package = "num-complex"
version = "=0.4.2"
features = ["std"]
default-features = false
[dependencies.num_cpus]
package = "num_cpus"
version = "=1.13.1"
[dependencies.num_integer]
package = "num-integer"
version = "=0.1.45"
features = ["i128", "std"]
[dependencies.num_iter]
package = "num-iter"
version = "=0.1.43"
features = ["i128", "std"]
[dependencies.num_rational]
package = "num-rational"
version = "=0.4.1"
features = ["num-bigint", "num-bigint-std", "std"]
default-features = false
[dependencies.num_threads]
package = "num_threads"
version = "=0.1.6"
[dependencies.num_traits]
package = "num-traits"
version = "=0.2.15"
features = ["i128", "libm", "std"]
[dependencies.object]
package = "object"
version = "=0.28.4"
features = ["archive", "coff", "elf", "macho", "pe", "read_core", "unaligned"]
default-features = false
[dependencies.once_cell]
package = "once_cell"
version = "=1.13.0"
features = ["alloc", "race", "std"]
[dependencies.opaque_debug]
package = "opaque-debug"
version = "=0.3.0"
[dependencies.openssl]
package = "openssl"
version = "=0.10.40"
[dependencies.openssl_macros]
package = "openssl-macros"
version = "=0.1.0"
[dependencies.openssl_probe]
package = "openssl-probe"
version = "=0.1.5"
[dependencies.openssl_sys]
package = "openssl-sys"
version = "=0.9.74"
[dependencies.ordered_float]
package = "ordered-float"
version = "=2.10.0"
features = ["std"]
[dependencies.os_str_bytes]
package = "os_str_bytes"
version = "=6.1.0"
features = ["raw_os_str"]
default-features = false
[dependencies.parking_lot]
package = "parking_lot"
version = "=0.12.1"
[dependencies.parking_lot_core]
package = "parking_lot_core"
version = "=0.9.3"
[dependencies.paste]
package = "paste"
version = "=1.0.7"
[dependencies.percent_encoding]
package = "percent-encoding"
version = "=2.1.0"
[dependencies.pest]
package = "pest"
version = "=2.1.3"
[dependencies.petgraph]
package = "petgraph"
version = "=0.6.2"
features = ["graphmap", "matrix_graph", "stable_graph"]
[dependencies.phf]
package = "phf"
version = "=0.10.1"
features = ["std"]
[dependencies.phf_0_8_0]
package = "phf"
version = "=0.8.0"
features = ["std"]
[dependencies.phf_codegen]
package = "phf_codegen"
version = "=0.8.0"
[dependencies.phf_generator]
package = "phf_generator"
version = "=0.10.0"
[dependencies.phf_generator_0_8_0]
package = "phf_generator"
version = "=0.8.0"
[dependencies.phf_shared]
package = "phf_shared"
version = "=0.10.0"
features = ["std"]
[dependencies.phf_shared_0_8_0]
package = "phf_shared"
version = "=0.8.0"
features = ["std"]
[dependencies.pin_project]
package = "pin-project"
version = "=1.0.11"
[dependencies.pin_project_internal]
package = "pin-project-internal"
version = "=1.0.11"
[dependencies.pin_project_lite]
package = "pin-project-lite"
version = "=0.2.9"
[dependencies.pin_utils]
package = "pin-utils"
version = "=0.1.0"
[dependencies.pkg_config]
package = "pkg-config"
version = "=0.3.25"
[dependencies.png]
package = "png"
version = "=0.17.5"
[dependencies.postgres]
package = "postgres"
version = "=0.19.3"
[dependencies.postgres_protocol]
package = "postgres-protocol"
version = "=0.6.4"
[dependencies.postgres_types]
package = "postgres-types"
version = "=0.2.3"
[dependencies.ppv_lite86]
package = "ppv-lite86"
version = "=0.2.16"
features = ["simd", "std"]
[dependencies.precomputed_hash]
package = "precomputed-hash"
version = "=0.1.1"
[dependencies.proc_macro2]
package = "proc-macro2"
version = "=1.0.40"
features = ["proc-macro", "span-locations"]
[dependencies.proc_macro_error]
package = "proc-macro-error"
version = "=1.0.4"
features = ["syn", "syn-error"]
[dependencies.proc_macro_error_attr]
package = "proc-macro-error-attr"
version = "=1.0.4"
[dependencies.proc_macro_hack]
package = "proc-macro-hack"
version = "=0.5.19"
[dependencies.psl_types]
package = "psl-types"
version = "=2.0.10"
[dependencies.publicsuffix]
package = "publicsuffix"
version = "=2.1.1"
features = ["idna", "punycode"]
[dependencies.quote]
package = "quote"
version = "=1.0.20"
features = ["proc-macro"]
[dependencies.rand]
package = "rand"
version = "=0.8.5"
features = ["alloc", "getrandom", "libc", "rand_chacha", "serde", "serde1", "small_rng", "std", "std_rng"]
[dependencies.rand_0_7_3]
package = "rand"
version = "=0.7.3"
features = ["alloc", "getrandom", "getrandom_package", "libc", "rand_pcg", "small_rng", "std"]
[dependencies.rand_chacha]
package = "rand_chacha"
version = "=0.3.1"
features = ["std"]
[dependencies.rand_chacha_0_2_2]
package = "rand_chacha"
version = "=0.2.2"
features = ["std"]
default-features = false
[dependencies.rand_core]
package = "rand_core"
version = "=0.6.3"
features = ["alloc", "getrandom", "serde", "serde1", "std"]
[dependencies.rand_core_0_5_1]
package = "rand_core"
version = "=0.5.1"
features = ["alloc", "getrandom", "std"]
[dependencies.rand_distr]
package = "rand_distr"
version = "=0.4.3"
features = ["alloc", "std"]
[dependencies.rand_pcg]
package = "rand_pcg"
version = "=0.2.1"
[dependencies.rawpointer]
package = "rawpointer"
version = "=0.2.1"
[dependencies.rayon]
package = "rayon"
version = "=1.5.3"
[dependencies.rayon_core]
package = "rayon-core"
version = "=1.9.3"
[dependencies.regex]
package = "regex"
version = "=1.6.0"
features = ["aho-corasick", "memchr", "perf", "perf-cache", "perf-dfa", "perf-inline", "perf-literal", "std", "unicode", "unicode-age", "unicode-bool", "unicode-case", "unicode-gencat", "unicode-perl", "unicode-script", "unicode-segment"]
[dependencies.regex_automata]
package = "regex-automata"
version = "=0.1.10"
default-features = false
[dependencies.regex_syntax]
package = "regex-syntax"
version = "=0.6.27"
features = ["unicode", "unicode-age", "unicode-bool", "unicode-case", "unicode-gencat", "unicode-perl", "unicode-script", "unicode-segment"]
[dependencies.remove_dir_all]
package = "remove_dir_all"
version = "=0.5.3"
[dependencies.reqwest]
package = "reqwest"
version = "=0.11.11"
features = ["__tls", "blocking", "cookie_crate", "cookie_store", "cookies", "default-tls", "hyper-tls", "json", "mime_guess", "multipart", "native-tls-crate", "proc-macro-hack", "serde_json", "tokio-native-tls"]
[dependencies.ring]
package = "ring"
version = "=0.16.20"
features = ["alloc", "dev_urandom_fallback", "once_cell"]
[dependencies.rusqlite]
package = "rusqlite"
version = "=0.27.0"
features = ["array", "backup", "blob", "bundled", "bundled-full", "chrono", "collation", "column_decltype", "csv", "csvtab", "extra_check", "functions", "hooks", "i128_blob", "limits", "load_extension", "modern-full", "modern_sqlite", "serde_json", "series", "time", "trace", "unlock_notify", "url", "uuid", "vtab", "window"]
[dependencies.rustc_demangle]
package = "rustc-demangle"
version = "=0.1.21"
[dependencies.rustc_version]
package = "rustc_version"
version = "=0.4.0"
[dependencies.ryu]
package = "ryu"
version = "=1.0.10"
[dependencies.safe_arch]
package = "safe_arch"
version = "=0.6.0"
features = ["bytemuck"]
[dependencies.same_file]
package = "same-file"
version = "=1.0.6"
[dependencies.scoped_threadpool]
package = "scoped_threadpool"
version = "=0.1.9"
[dependencies.scopeguard]
package = "scopeguard"
version = "=1.1.0"
features = ["use_std"]
[dependencies.select]
package = "select"
version = "=0.5.0"
[dependencies.semver]
package = "semver"
version = "=1.0.12"
features = ["std"]
[dependencies.semver_parser]
package = "semver-parser"
version = "=0.10.2"
[dependencies.serde]
package = "serde"
version = "=1.0.138"
features = ["derive", "rc", "serde_derive", "std"]
[dependencies.serde_derive]
package = "serde_derive"
version = "=1.0.138"
[dependencies.serde_json]
package = "serde_json"
version = "=1.0.82"
features = ["raw_value", "std"]
[dependencies.serde_urlencoded]
package = "serde_urlencoded"
version = "=0.7.1"
[dependencies.serde_value]
package = "serde-value"
version = "=0.7.0"
[dependencies.serde_yaml]
package = "serde_yaml"
version = "=0.8.24"
[dependencies.sha1]
package = "sha1"
version = "=0.6.1"
[dependencies.sha1_smol]
package = "sha1_smol"
version = "=1.0.0"
[dependencies.sha2]
package = "sha2"
version = "=0.10.2"
features = ["std"]
[dependencies.signal_hook_registry]
package = "signal-hook-registry"
version = "=1.4.0"
[dependencies.simba]
package = "simba"
version = "=0.7.1"
features = ["std", "wide"]
default-features = false
[dependencies.siphasher]
package = "siphasher"
version = "=0.3.10"
features = ["std"]
[dependencies.slab]
package = "slab"
version = "=0.4.6"
features = ["std"]
[dependencies.smallvec]
package = "smallvec"
version = "=1.9.0"
[dependencies.smawk]
package = "smawk"
version = "=0.3.1"
[dependencies.socket2]
package = "socket2"
version = "=0.4.4"
features = ["all"]
[dependencies.spin]
package = "spin"
version = "=0.9.3"
features = ["barrier", "lazy", "lock_api", "lock_api_crate", "mutex", "once", "rwlock", "spin_mutex"]
[dependencies.spin_0_5_2]
package = "spin"
version = "=0.5.2"
[dependencies.string_cache]
package = "string_cache"
version = "=0.8.4"
features = ["serde", "serde_support"]
[dependencies.string_cache_codegen]
package = "string_cache_codegen"
version = "=0.5.2"
[dependencies.stringprep]
package = "stringprep"
version = "=0.1.2"
[dependencies.strsim]
package = "strsim"
version = "=0.10.0"
[dependencies.subtle]
package = "subtle"
version = "=2.4.1"
default-features = false
[dependencies.syn]
package = "syn"
version = "=1.0.98"
features = ["clone-impls", "derive", "extra-traits", "fold", "full", "parsing", "printing", "proc-macro", "quote", "visit", "visit-mut"]
[dependencies.tar]
package = "tar"
version = "=0.4.38"
features = ["xattr"]
[dependencies.tempfile]
package = "tempfile"
version = "=3.3.0"
[dependencies.tendril]
package = "tendril"
version = "=0.4.3"
[dependencies.termcolor]
package = "termcolor"
version = "=1.1.3"
[dependencies.terminal_size]
package = "terminal_size"
version = "=0.1.17"
[dependencies.textwrap]
package = "textwrap"
version = "=0.15.0"
features = ["smawk", "terminal_size", "unicode-linebreak", "unicode-width"]
[dependencies.thiserror]
package = "thiserror"
version = "=1.0.31"
[dependencies.thiserror_impl]
package = "thiserror-impl"
version = "=1.0.31"
[dependencies.thread_id]
package = "thread-id"
version = "=4.0.0"
[dependencies.thread_local]
package = "thread_local"
version = "=1.1.4"
[dependencies.threadpool]
package = "threadpool"
version = "=1.8.1"
[dependencies.tiff]
package = "tiff"
version = "=0.7.2"
[dependencies.time]
package = "time"
version = "=0.3.11"
features = ["alloc", "formatting", "itoa", "macros", "parsing", "std", "time-macros"]
[dependencies.time_0_1_44]
package = "time"
version = "=0.1.44"
[dependencies.time_macros]
package = "time-macros"
version = "=0.2.4"
[dependencies.tinyvec]
package = "tinyvec"
version = "=1.6.0"
features = ["alloc", "grab_spare_slice", "rustc_1_40", "rustc_1_55", "serde", "std", "tinyvec_macros"]
[dependencies.tinyvec_macros]
package = "tinyvec_macros"
version = "=0.1.0"
[dependencies.tokio]
package = "tokio"
version = "=1.19.2"
features = ["bytes", "fs", "full", "io-std", "io-util", "libc", "macros", "memchr", "mio", "net", "num_cpus", "once_cell", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "signal-hook-registry", "socket2", "sync", "test-util", "time", "tokio-macros", "winapi"]
[dependencies.tokio_io]
package = "tokio-io"
version = "=0.1.13"
[dependencies.tokio_macros]
package = "tokio-macros"
version = "=1.8.0"
[dependencies.tokio_native_tls]
package = "tokio-native-tls"
version = "=0.3.0"
[dependencies.tokio_postgres]
package = "tokio-postgres"
version = "=0.7.6"
features = ["runtime"]
[dependencies.tokio_util]
package = "tokio-util"
version = "=0.7.3"
features = ["codec", "tracing"]
[dependencies.toml]
package = "toml"
version = "=0.5.9"
[dependencies.tower_service]
package = "tower-service"
version = "=0.3.2"
[dependencies.tracing]
package = "tracing"
version = "=0.1.35"
features = ["std"]
default-features = false
[dependencies.tracing_core]
package = "tracing-core"
version = "=0.1.28"
features = ["once_cell", "std"]
default-features = false
[dependencies.traitobject]
package = "traitobject"
version = "=0.1.0"
[dependencies.try_lock]
package = "try-lock"
version = "=0.2.3"
[dependencies.typemap]
package = "typemap"
version = "=0.3.3"