Drop support for Ruby v2.5 and Node.js v12 (#18323)

* Drop support for Ruby v2.5 and Node.js v12

* Update package.json
rebase/4.0.0rc1
Yamagishi Kazutoshi 7 months ago committed by GitHub
parent e789b8d4c1
commit 4e26fb0ea9
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
  1. 4
      README.md
  2. 2
      package.json

@ -72,8 +72,8 @@ Mastodon acts as an OAuth2 provider, so 3rd party apps can use the REST and Stre
- **PostgreSQL** 9.5+
- **Redis** 4+
- **Ruby** 2.5+
- **Node.js** 12+
- **Ruby** 2.6+
- **Node.js** 14+
The repository includes deployment configurations for **Docker and docker-compose** as well as specific platforms like **Heroku**, **Scalingo**, and **Nanobox**. The [**standalone** installation guide](https://docs.joinmastodon.org/admin/install/) is available in the documentation.

@ -2,7 +2,7 @@
"name": "@mastodon/mastodon",
"license": "AGPL-3.0-or-later",
"engines": {
"node": ">=12"
"node": ">=14"
},
"scripts": {
"postversion": "git push --tags",

Loading…
Cancel
Save